Plesk

WordPress website hosted in Plesk is not accessible with a 500 or 503 error

Symptoms

Cause

Coding issue on the WordPress instance caused by malfunctioning plugins, theme and/or customization.

Resolution

  1. Log in to Plesk GUI
  2. Go to Domains > example.com > Click on WordPress instance > Instances tab > Plugins tab.
  3. Disable all WordPress plugins.
  4. Enable WordPress plugins one by one and check the website accessibility until the problematic plugin is found.
  5. Enable all non-problematic WordPress plugins.

    Note: Once the problematic WordPress plugin is identified, contact WordPress plugin developers and change current PHP settings if required.

  6. If this did not fix the issue, verify the following:

    • The installed WordPress plugins are up to date

    • The installed WordPress plugins are compatible with the other WordPress plugins

    • The installed WordPress theme is up to date

    • The installed WordPress theme is compatible with the WordPress plugins
    • Both WordPress plugins and theme are compatible with the current PHP version and PHP configuration