Plesk

WordPress update via Smart Update fails in Plesk: Smart Update was unable to correctly clone your website for further analysis

Symptoms

Cause

Product issue:

  • #EXTWPTOOLK-3611 "Smart Updates will now properly work if sitemap of the cloned website differs from the original due to meddling of certain plugins."
    Fixed in:

Resolution

Consider updating your server:

Workaround

If update is not possible for some reason, try the following:

workaround

As a workaround, manually create a smart-update-sitemap.xml and upload it to the instance's Document Root directory:

  1. Go to XML-Sitemaps.com website;

  2. Enter the website URL (for i.e: https://example.com) to create a sitemap for the instance:


  3. Click Start;

  4. Click Download your XML Sitemap File Download:


  5. When downloaded, rename the file from sitemap.xml to smart-update-sitemap.xml;

  6. Log in to Plesk;
  7. Go to Domains > example.com > File Manager > httpdocs > Upload the smart-update-sitemap.xml file.

    Note: The default Document Root is httpdocs. This can be confirmed at Plesk > Domains > example.com > Hosting Settings > Document Root. In case a custom one is used, upload the file accordingly.