Plesk

WordPress instance inside a sub-directory on Plesk server shows “404 Page not found” errors for existing categories or posts

Symptoms

Cause

Product issue:

  • #EXTWPTOOLK-8578 "Block author scans and Enable bot protection security measures no longer break WordPress sites installed in a subdirectory."

    Fixed in:

Resolution

Please consider updating your server:

Workaround

Apply one of the following workarounds:

Use "Plain" permalinks:

  1. Login to the WordPress admin Dashboard of the sub-directory instance.
  2. Go to Serttings > Permalinks page.
  3. Select Plain option and click Save Changes.

Revert Security Measures "Block author scans" and "Enable bot protection":

Revert the Security Measures "Block author scans" and "Enable bot protection" on the main WordPress instance (/httpdocs) and under WordPress instances installed to subdirectories (e.g. /httpdocs/test), as described below:

  1. Log into Plesk.
  2. Go to Domains > example.com > WordPress > select the WordPress instance in question > Security Status or Security page and press Check Security button.​
  3. Select Block author scans and Enable bot protection, if both are found applied, otherwise select the one found and press Revert button: