Plesk

Website on Plesk returns webserver default page instead of the website content

Symptoms

Cause

The index file was renamed, moved, or removed.

Resolution

If the index file was removed, restore it from a backup or recreate it.

If the index file was renamed or moved, perform one of the following resolutions:

If the website uses the renamed index file for its correct working capacity

  1. Log in to Plesk.

  2. Go to Domains > example.com > Apache & nginx Settings.

  3. Switch the Index files directive to Enter custom value.

  4. Insert the name of the file which is used instead of default index.* file.

  5. Press the OK button to apply changes.

  6. Go to Domains > example.com > File Manager and make sure that the custom index file is present in the opened folder.

  7. If the custom index file is located in another folder, move it to the website Document root folder (can be found on the Domains > example.com > Hosting Settings page) by selecting this file in the File Manager and clicking the Move button:

If the website uses the default "index.*" file

  1. Log in to Plesk.

  2. Go to Domains > example.com > File Manager.

  3. Find the renamed file and rename it back to the correct one (the correct name depends on the file content):

    • index.html

    • index.cgi

    • index.pl

    • index.php

    • index.xhtml

    • index.htm

    • index.shtml

    by clicking the  > Rename button:

  4. If the index.* file is located in another folder, move it to the website Document root folder (can be found on the Domains > example.com > Hosting Settings page) by selecting this file in the File Manager and clicking the Move button: