Plesk

Website hosted on Plesk is not working: Microsoft OLE DB Provider for SQL Server error ‘80004005’

Symptoms

Cause

Corrupted log file %plesk_dir%DatabasesMSSQLMSSQLXX.MSSQLSERVERXXXXMSSQLDATAdbname.ldf.

Note: XX and XXXX correspond to the SQL Server version.

Resolution

  1. Connect to the server using RDP

  2. Determine SQL Server service name:

    C:> sc query | findstr MSSQL | findstr SERVICE_NAME
    SERVICE_NAME: MSSQL$MSSQLSERVER2017
    SERVICE_NAME: MSSQLFDLauncher$MSSQLSERVER2017
    SERVICE_NAME: SQLTELEMETRY$MSSQLSERVER2017

  3. Stop SQL service:

    C:> net stop MSSQL$MSSQLSERVER2017

  4. Rename log file %plesk_dir%DatabasesMSSQLMSSQLXX.MSSQLSERVERXXXXMSSQLDATAdbname.ldf:

    C:> move %plesk_dir%DatabasesMSSQLMSSQLXX.MSSQLSERVERXXXXMSSQLDATAdbname.ldf %plesk_dir%DatabasesMSSQLMSSQLXX.MSSQLSERVERXXXXMSSQLDATAdbname.ldf.bkp

  5. Start SQL Server:

    C:> net start MSSQL$MSSQLSERVER2017

    Note: In order to find the root cause why the database log file got corrupted, contact Microsoft support.

In case the issue persists, re-enable the database

  1. Connect to the server via RDP

  2. Open Microsoft SQL Server Management Studio and log into affected SQL Server instance as Windows Administrator

  3. Execute the following queries through New Query:

    USE master
    GO
    ALTER DATABASE dbname
    SET OFFLINE WITH ROLLBACK IMMEDIATE
    GO
    USE MASTER
    GO
    ALTER DATABASE dbname
    SET ONLINE
    GO

Exit mobile version