Plesk

Webmail/domain is unavailable: Server not found

Symptoms

Cause

Webmail/domain does not resolve correctly in global DNS system because Plesk server is not set up to manage DNS.

Resolution

To verify the root cause, run the following commands in a command-line interface:

Note: the commands are identical on Windows, Linux and MacOS. The commands below are valid for webmail as well

  1. First, test if domain can be resolved to an IP address in general:

    C:> nslookup example.com
    Server: mydns.server.com
    Address: 203.0.113.2

    Non-authoritative answer:
    Name: example.com
    Address: 203.0.115.20

    Output explanation:

    • Server and Address represent hostname and address of the server that provides response for the query sent by command nslookup;
    • Name and Address(es) are the domain name which IP address is being queried and the IP address that was provided by the server as a response.

    However, if the following output is seen instead, it means that the domain does not resolve properly:

    C:> nslookup webmail.example.com
    Server: mydns.server.com
    Address: 203.0.113.2

    *** UnKnown can't find example.com: No response from server

  2. Next, check if DNS service on the server with Plesk contains proper record for the domain:

    C:> nslookup webmail.example.com 203.0.115.20 <---- IP address of the server with Plesk
    Server: UnKnown
    Address: 203.0.115.20

    Name: webmail.example.com
    Address: 203.0.115.20

If the first command does not return anything or returns a wrong IP address, and the second command returns valid records, then Plesk server is not serving the DNS zone for a domain.

There are two options to resolve the issue:

Note: a similar issue can be observed for other DNS records like TXT, MX, CNAME and etc.