Plesk

Unable to start Plesk Premium Antivirus ( Dr.Web ) on Plesk server

Symptoms

Cause

drweb package is corrupted or installed from the 3rd-party repository.

Resolution

  1. Connect to the server via SSH.

    Note: if direct SSH access to the server is not possible, contact server administrator for further assistance.

  2. Remove Plesk Premium Antivirus:

    # plesk installer --select-release-current --remove-component drweb

  3. Remove corresponding directories:

    # rm -rf /var/drweb/ /etc/drweb/

  4. Check if 3rd party repository is being used:

    # yum repolist | grep -i drweb
    drweb DrWeb - stable 72

    • If yes, disable it:
      Edit corresponding repository file and change enabled option to 0:

      # grep enabled /etc/yum.repos.d/drweb-yum-x86_64.repo
      enabled=0

      Note: the repository name may differ.

  5. Re-install Plesk Premium Antivirus:

    • via Plesk UI:

      In Plesk> Tools & Settings > Updates and Upgrades > Add and Remove Product Components > Mail hosting > Plesk Premium Antivirus:

    • via command-line interface:

      # plesk installer --select-release-current --install-component drweb

  6. Run the Plesk Premium Antivirus service:

    • via Plesk UI:

      Tools & Settings > Services Management > Plesk Premium Antivirus:

    • via command-line interface:

      # service drwebd start