Plesk

Unable to start Plesk migration: Migrator cannot connect to source RPC agent

Symptoms

Cause

This is Windows Migrator Agent bug with ID #PMT-4386 which is planned to be fixed in future updates.

Resolution

Note: if you don't have administrative access to Plesk via RDP, contact your hosting provider regarding the issue

Note: This behavior can be caused by an antivirus software being active in the source server which, in such cases, should be disabled to proceed with the migration process

As a workaround:

  1. Connect to the destination server via RDP.

  2. Copy the following files (RPC agent and certificate files) manually from:

    • %plesk_dir%varmodulespanel-migratorthirdpartiespanel-migrator-rpc-agent*.*

    • %plesk_dir%varmodulespanel-migratorrpc-agentcertificates*.crt

    • %plesk_dir%varmodulespanel-migratorrpc-agentcertificatessource-node.key

    to C:panel_migratorrpc-agent.

  3. Connect to the source server via RDP.

  4. Go to C:panel_migratorrpc-agent and paste the copied files.

  5. Run run-panel-migrator-rpc-agent.exe in C:panel_migratorrpc-agentrpc-agent

    Note: Do not close the command line window.