Plesk

Unable to set mailbox size more than default size in Plesk: The specified limit is invalid

Symptoms

Cause

The custom mailbox size trying to be set on the mailbox is limited by the Subscription, Service Plan and/or Reseller's Service Plan settings:

Resolution

Note: If Plesk Web Admin edition is installed, apply the solution described here

  1. Log in to Plesk GUI

  2. Switch Plesk interface to the Service Provider View

  3. Change the default mailbox size limit for Subscription or for Service Plan or for Reseller. This depends on where the limit is configured in each specific case. There are 3 options:

    • Change limit in a Subscription:

      Go to Subscriptions > example.com > Click on Customize option available in the Account right sidebar section > Change Mailbox size > Click on Update & Lock to apply the changes

    • Change limit in a Service Plan:

      Go to Service Plans > Choose required Service Plan > Change Mailbox size > Click OK to apply the changes

    • Change limit in a Reseller:

      Go to Resellers > Click on the name of the Reseller > Click on Customize option available in the Resources right sidebar section > Change Mailbox size > Click on Update & Lock to apply the changes

Additional information

Unable to change maibox size: The specified limit is invalid