Plesk

Unable to send or receive e-mail messages: Hostname is not valid. Please set a hierarchical, dot-separated domain as the hostname

Symptoms

Cause

The server hostname must be a fully qualified domain name (FQDN). The hostname may either be incorrectly configured in Tools & Settings > Server Settings > Hostname or via hostname command.

Resolution

  1. Log into Plesk.

  2. Go to Tools & Settings > Server Settings and set a Full hostname.
    If hostname already set, change it to some random one (ex. test.example.com) and then change back to correct hostname. This will trigger the change to /etc/hostname as well.

  3. Open Plesk Email Security in Extensions > My extensions > Plesk Email Security > Open

  4. Click the button Install Now!

Additional information

Server with Plesk Email Security no longer sends/receives emails: [127.0.0.1]:10024: Connection refused