Plesk

Unable to send and receive via Plesk server with mail client due to SSL certificate: Mail can’t verify the identity of mail.example.com

Symptoms

Cause

Wrong certificate is set up for mail server in Plesk UI.

Resolution

Note: the domain name of mail server specified in mail client's settings must match domain name in the SSL/TLS certificate. Otherwise, SSL/TLS connections mail client will report about certificate issues.

  1. Log into Plesk
  2. In Plesk go to Tools & Settings and click SSL/TLS Certificates.
  3. Click Change next to Certificate for securing mail > select the valid certificate > click OK.

Additional information