Plesk

Unable to send an email to Gmail from a Plesk server: Our system has detected that this message does not meet IPv6 sending guidelines regarding PTR records

Symptoms

Cause

Gmail Guidelines for IPv6 are not met: the IPv6 address does not have a PTR record.

Resolution

Solution I: Contact your hosting provider to set up a reverse DNS for IPv6 address.

Solution II: Apply one of the following instructions:

 

Configuring mail server to use IPv4 only (Postfix)

 

  1. Log in to Plesk.

  2. Go to Tools & Settings > Mail Server Settings

  3. Under Outgoing mail mode select Send from the specified IP addresses:

    1. for IPv4 set the desired IPv4 address from the dropdown menu

    2. for IPv6 select None

  4. Click OK.

 

Disabling IPv6 addresses on the server

 

  1. Log in to Plesk.

  2. Go to Tools & Settings > IP Addresses > click on the Sites number next to IPv6. If there are domains hosted on IPv6, go to Domains > example.com > Web Hosting Access and switch these domains to IPv4 only.

  3. When you are sure no domains are using IPv6 in Plesk, connect to the Plesk via SSH and open the file /etc/sysctl.conf in a text editor. In this example, we are using the vi editor:

    # vi /etc/sysctl.conf

  4. Add the following lines:

    # grep ipv6 /etc/sysctl.conf
    net.ipv6.conf.all.disable_ipv6=1
    net.ipv6.conf.default.disable_ipv6=1

  5. Apply the changes with the following command:

    # sysctl -p

  6. Remove IPv6 addresses from Plesk: Click Reread IP at Tools & Settings > IP Addresses.

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