Plesk

Unable to select the Atomic Advanced (bought from Plesk) ruleset for ModSecurity when Security Pack and Advanced ModSecurity licenses are used: distributed_update Invalid user credentials

Symptoms

Cause

The license for Advanced ModSecurity Rules by Atomicorp is included in Server and Site Security Pack, so the separate license for ruleset causes the conflict.

Resolution

Remove the license key for Advanced ModSecurity Rules by Atomicorp ruleset. Note: replace Advanced ModSecurity Rules by Atomicorp with Server and Site Security Pack in the instructions below if it's functionality is not required:

  1. Log in to Plesk.
  2. Go to Tools & Settings > License Management > Additional License Keys, select the Advanced ModSecurity Rules by Atomicorp license and click Remove.
  3. Go to Tools & Settings > Web Application Firewall (ModSecurity) > Settings, select any free version and click OK to re-read the configuration
  4. On Tools & Settings > Web Application Firewall (ModSecurity) > Settings, select the Atomic Advanced (bought from Plesk) ruleset and click OK or Apply button to install the ruleset.
  5. Contact Plesk Customer Success Team to terminate the license for Advanced ModSecurity Rules by Atomicorp ruleset.
Exit mobile version