Plesk

Unable to reset the password for a Plesk user: To reset your password, contact your hosting provider

Symptoms

Note: in this article, an assumption is made that a Plesk User is a Customer in Plesk. In fact, the same is applicable to other Plesk users, like Resellers or Additional Users.

  1. It is not possible to reset the password for a Customer in Plesk. The following message arrives instead of password reset link:

    "We cannot send your password via email for security reasons. To reset your password, contact your hosting provider."

  2. Customer named Jonn Doe with the login john_doe is linked to john.doe@example.com mailbox.

  3. Customer John Doe does not own example.com:

  4. Domain example.com is hosted on the same server.

Cause

For security reasons, correct password reset email is sent only in case the account owner matches the mailbox owner to avoid possible data violations.

Resolution

  1. Log in to Plesk.

  2. Go to Customers > John Doe > Edit Contact Info. and change email for jdoe user to a mailbox @johndoe.tld that is owned by John Doe.

    As an alternative, it is possible to specify the mailbox @gmail or any other domain that is not hosted on the same server.

    If a Mail User is affected, set it as the External Mail under Domains > example.com > Mail Accounts > john.doe@example.com > General tab.