Plesk

Unable to receive mail from external domain: 5.7.23 SPF validation failed

Symptoms

Cause

The SPF check for example.com fails because of an incorrect or nonexistent SPF record on the sender side.

Resolution

Ask the sender to correct the SPF settings for his domain or apply one of the following workarounds:

Change SPF checking mode

  1. Log in to Plesk.
  2. Go to Tools & Settings > Mail Server Settings.
  3. Change SPF checking mode to less strict, for example, "Only create Received-SPF headers, never block".
  4. Scroll down and press the OK button to apply the changes. 

Add the sender domain to the exceptions

  1. Log in to Plesk.
  2. Go to Tools & Settings > Mail Server Settings.
  3. Add example.com to SPF local rules  and SPF guess rules fields as described here.
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