Plesk

 Unable to open Updates & Upgrades on Plesk for Linux: ERR_CONNECTION_TIMED_OUT

Symptoms

Cause

Port 8447 that is used by Plesk Installer is filtered/closed with a firewall.

Resolution

Open port 8447 in the firewall:

Note: if this is an Amazon installation, refer to this documentation page.

Note: if this is a Google installation, refer to this documentation page.

Opening port via Plesk

  1. Log in to Plesk.

  2. Go to Tools & Settings > Firewall and click the Enable button.

    Note: If the Plesk Firewall component is not installed/missing, move to the command-line section.

  3. Click the rule Plesk installer > select Allow > and click OK.

  4. If port 8447 is still filtered/closed, check if there are any intermediate firewalls.

    Contact a network administrator for further troubleshooting.

Opening port via a Command Line Interface (CLI) in Linux

  1. Connect to the server via SSH.

  2. Check the status of port 8447:

    # iptables -nL | grep 8447

  3. For some Linux distributions (CentOS 7, Debian, Ubuntu), additional package iptables-persistent or iptables-services is required to be installed before running iptables-save:

    • For CentOS 7:

      # yum install iptables-services
      # systemctl enable iptables-services

    • For Debian:

      # apt install iptables-persistent

  4. Allow incoming connections to port 8447:

    • For CentOS/RHEL-based distributions:

      # iptables -I INPUT 1 -p tcp --dport=8447 -j ACCEPT
      # service iptables save

    • For Debian/Ubuntu-based distributions:

      # iptables -I INPUT 1 -p tcp --dport=8447 -j ACCEPT
      # iptables-save > /etc/iptables/rules.v4

  5. If port 8447 is still filtered/closed, check if there are any intermediate firewalls.

Contact a network administrator for further troubleshooting.

Alternatively it is possible to use command line interface (CLI) of plesk installer: How to install / uninstall Plesk components?

Additional Information

Exit mobile version