Plesk

Unable to open subdomain, alias or webmail hosted in Plesk: This site can’t be reached DNS_PROBE_FINISHED_NXDOMAIN

Symptoms

Cause

Missing DNS record (type CNAME) for www.example.com or (type A) for subdomain one.example.com or webmail webmail.example.com.

Resolution

Verify what name servers are used to serve DNS for example.com:

  1. Go to the online NS record checker (for instance this one: Online tool for NS server check) and find what name servers are used for example.com;
  2. Check if the NS servers are the same as in the Domains > example.com > DNS Settings (NS records). If they are, then DNS service is managed by Plesk.
    If different name servers are used, or the option Domains > example.com > DNS Settings is absent, 3rd party name server provider is used (i.e. DNS provider).

If DNS zone is managed by DNS server in Plesk

  1. Log in to Plesk GUI

  2. Go to Domains > example.com > DNS Settings > click Add Record

  3. For www.example.com, add a CNAME record: 


    For one.example.com or webmail.example.com, add an A-record:

  4. Click the OK button.

If DNS zone is managed by DNS provider

Contact DNS provider (registrar side) to create required CNAME or A-record.

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