Plesk

Unable to login to Plesk via SSH with root user after deleting Imunify360

Symptoms

Cause

The Imunify360 extension has been recently deleted from the server, however, its leftovers are still present in the /etc/pam.d/system-auth and /etc/pam.d/password-auth configuration files.

Resolution

  1. Log in to Plesk.

  2. Install SSH Terminal extension and login to the server.

  3. Comment out corresponding lines in /etc/pam.d/system-auth and /etc/pam.d/password-auth as follows, e.g. using Vi:

    #%PAM-1.0
    ...
    #auth required pam_imunify.so check_only
    ...
    #auth required pam_imunify.so
    ...

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