Plesk

Unable to log in to Roundcube/Horde webmail in Plesk: ssl_cert: Can’t open file

Symptoms

Cause

The SSL certificate file for securing domain's mail does not exist in the system. 

Resolution

  1. Connect to the Plesk server via SSH.

  2. Check if the domain from the error message exist in Plesk with the command:

    # plesk bin site --list | grep example.com

     

If the domain exist

 

  1. Repair SSL certificates:

    # plesk repair web -sslcerts

  2. Restart the Dovecot service:

    # service dovecot restart

 

If the service still fails to start, apply the following steps: 

  1. Log in to Plesk.

  2. Go to Domains > example.com > Mail Settings.

  3. Set the option SSL/TLS certificate for mail to "Not selected" and apply the changes.

  4. Select SSL certificate back and apply the changes.

 

If the domain does not exist

 

  1. Remove the orphaned configuration files:

    Note: Replace example.com with the domain name from the error message.

    # rm -f /etc/dovecot/conf.d/14-plesk-sni-example.com.conf

    # rm -f /etc/dovecot/conf.d/14-plesk-sni-mail.example.com.conf

  2. Check Dovecot configuration:

    # dovecot -F

  3. Restart the Dovecot service:

    # service dovecot restart