Plesk

Unable to log in to Plesk as a Plesk administrator: Access for administrator from address 203.0.113.2 is restricted in accordance with IP Access restriction policy currently applied

Symptoms

It is not possible to log in to Plesk as a Plesk administrator with the following message:

Access for administrator from address 203.0.113.2 is restricted in accordance with IP Access restriction policy currently applied.

Cause

The current Plesk IP access policy does not allow to log in from a particular IP address.

This setting is configured in Plesk at Tools & Settings > Restrict Administrative Access.

Resolution

Apply one of the following solutions:

 

Add your IP address to the list of allowed IP addresses
  1. Connect to the Plesk server via SSH (Linux) / RDP (Windows Server).

  2. Add your IP address to the allow list (on Windows Server, use command prompt as an Administrator):

     

    # plesk db "INSERT INTO cp_access (type, netaddr, netmask) VALUES ('deny' , '203.0.113.2', '255.255.255.255')"

     

    • where 203.0.113.2 - the IP address of a device from which you are accessing Plesk

 

Disable the IP Restriction Policy

 

  • For Plesk on Linux
    1. Connect to the Plesk server via SSH.

    2. For security reasons, create a dump of the Plesk database.

    3. Clear the access policy settings:

      3.1. Remove all records from the "cp_access" table:

      # plesk db "DELETE FROM cp_access"

      3.2. Set the policy to allow:

      # plesk db "UPDATE misc SET val='allow' WHERE param='access_policy'"

 

  • For Plesk on Windows

    1. Connect to the Plesk server via RDP and start a command prompt as an Administrator.

    2. For security reasons, create a dump of the Plesk database.

    3. Clear the access policy settings:

      3.1. Remove all records from the "cp_access" table:

      C:> plesk db "DELETE FROM cp_access"

      3.2. Set the policy to allow:

      C:> plesk db "UPDATE misc SET val='allow' WHERE param='access_policy'"

 

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