Plesk

Unable to install Let’s Encrypt certificate for the domain hosted in Plesk: SERVFAIL looking up A for example.com

Symptoms

Cause

The DNS A type record does not exist or DNS propagation is not completed.

Resolution

Add the A DNS record type for the domain:

If it is not clear what NS servers are managing DNS for the domain:

  1. Go to the online NS record checker (for instance this one: Online tool for NS server check);
  2. Check if the NS servers are the same with the Domains > exmple.com > DNS Settings. If they are, then your DNS is managed by Plesk.
    If there are not matching or the option Domains > example.com > DNS Settings is absent, thus, 3-d party DNS server is used (i.e. DNS provider).

If DNS is managed in Plesk:

  1. Log into Plesk;

  2. Add record (type A) for the example.com in Plesk > Domains > example.com > DNS Settings > Add Record:

  3. Click OK.

If DNS is managed by a 3d-party DNS provider:

Contact the domain provider in order to add appropriate A record

Note: If record has been already added, but the error persist, it is required to wait for a while. DNS propagation may take up to 72 hours. Use this tool in order to check global DNS propagation: DNS Propagation Check.