Plesk

Unable to import/migrate/restore a SQL database in Plesk: The database was backed up on a server running version xxxx. That version is incompatible with this server

Symptoms

Cause

Microsoft SQL database cannot be restored on an SQL server with a lower version.

Resolution

  1. Log in to Plesk (on the target server, in case of migration).

  2. Go to Tools & Settings > Database Servers, and check if there is a server with .MSSQLSERVER2017 Host name .

    • If MSSQLSERVER2017 (version that is being migrated) is already installed in Tools & Settings > Database Servers:

    Select newer version as default on a service plan level

    1. Log in to Plesk on the target server.
    2. Go to Service Plans > plan_name > Hosting Parameters and set newer MSSQL version as Default Database Server. MSSQL version should be the same or higher then on source server.
    • If there is no installed MSSQLSERVER2017 (version that is being migrated) in Tools & Settings > Database Servers, use one of the following solutions depending on the situation:

    Migration

    1. Log in to Plesk on the target server.
    2. Install Microsoft SQL Server (SQL2017) at Tools & Settings > Updates & Upgrades
    3. Go to Tools & Settings > Database Servers, select MSSQLSERVER2017 > Settings > check Use this server as default for MS SQL.
    4. Re-sync database files under Tools & Settings > Migration & Transfer Manager > <migration_session> > Overview > re-sync next to the affected subscription > select Migrate database data (tables, rows, etc).
    5. Change default server for MSSQL back to initial one.

    Database backup restoration

    1. Log in to Plesk.
    2. Install Microsoft SQL Server (SQL2017) at Tools & Settings > Updates & Upgrades
    3. Go to Tools & Settings > Database Servers, select .MSSQLSERVER2017 > Settings > check Use this server as default for MS SQL.
    4. Restore database from the backup.

Additional information

ALTER DATABASE (Transact-SQL) Compatibility Level