Plesk

Unable to create a domain alias in Plesk: DNS record already exists

Symptoms

When creating a new domain alias, the operation fails with the following error message in Plesk (in this example, domain alias example.net for example.com):

Error: Unable to add the ipv4.example.net. IN A 203.0.113.2 record to zone example.net: DNS record already exists.

Cause

The domain, for which a domain alias is created, contains duplicate DNS records.

In this example, there is a duplicate DNS entry for example.com that points to the same IP address 203.0.113.2 at Domains > example.com > DNS Settings.

Resolution

  1. In Plesk, go to Domains > example.com > DNS Settings.
  2. Select the duplicate DNS entries and remove them.

  3. On the next page, click Update to apply the changes.