Plesk

Unable to access WP Toolkit: A table must have a primary key, but none was found for table ‘Instances’

Symptoms

Cause

WP Toolkit SQLITE3 database was not created correctly or has been corrupted.

Resolution

It is required to reinstall WP Toolkit. It is possible to do that via Plesk Interface or via SSH.

Via Plesk Interface (click to reveal the details)

  1. Log into Plesk;
  2. Go to Tools & Settings > Updates and Upgrades > Add/Remove Components;
  3. Select WP Toolkit under Plesk Extensions and select Remove:
  4. Use the same steps to install WP Toolkit back.

Via SSH (click to reveal the details)

  1. Log into the server via SSH.

  2. Remove WP Toolkit component:

    # plesk installer remove --components wp-toolkit

  3. Install WP Toolkit component:

    # plesk installer add --components wp-toolkit