Plesk

Unable to access Plesk: /opt/psa/admin/bin/dnsmng: not found

Symptoms

Cause

Product issue:

  • #PPPM-13466 "Plesk updates no longer fail on Plesk servers that do not have BIND installed and are using a different DNS server."
    Fixed in:

Resolution

Please consider updating your server:

Workaround

If update is not possible for some reason you may try the following

workaround

The issue should be fixed in 18.0.42.1 on March 15, 2022.

As the workaround:

  1. Install bind9 component via Plesk > Tools & Settings > Updates> Add/Remove Components> BIND DNS server or using the plesk installer command:

    # plesk installer add --components bind

  2. Repair DNS configuration

    # plesk repair dns -y