Plesk

Unable to access Advanced Monitoring in Plesk: Dashboard not found

Symptoms

Advanced Monitoring doesn't show any data but one of the error messages below instead:

Dashboard not found


*If you're seeing this Grafana has failed to load its application files*
1. This could be caused by your reverse proxy settings.
2. If you host grafana under subpath make sure your grafana.ini root_url
setting includes subpath
3. If you have a local dev build make sure you build frontend using:
yarn start, yarn start:hot, or yarn build
4. Sometimes restarting grafana-server can help

Cause

Incorrect permissions inside sw-cp-server proxy directory.


Corrupted installation of the extensions Grafana and Advanced Monitoring.

Resolution

  1. Connect to the server via SSH.

  2. Make sure that subdirectories of /var/lib/sw-cp-server/proxy are owned by sw-cp-server:sw-cp-server:

    # ls -la /var/lib/sw-cp-server/proxy
    total 48
    drwx------ 12 sw-cp-server root 4096 Jun 16 13:55 .
    drwx------ 7 sw-cp-server sw-cp-server 4096 Jun 14 18:00 ..
    drwx------ 5 sw-cp-server sw-cp-server 4096 Jun 16 14:22 0
    ...
    drwx------ 6 sw-cp-server sw-cp-server 4096 Jun 16 14:23 3

  3. In case permissions/ownership are different, remove the proxy directory:

    # rm -rf /var/lib/sw-cp-server/proxy

In case the issue is not resolved,

reinstall the extension:

  1. Log in to Plesk.

  2. Remove the following extensions:

    • Extensions > My Extensions > Grafana > More > Remove and,

    • Extensions > My Extensions > Advanced Monitoring > More > Remove.

      Warning: Please note all the customization to Advanced Monitoring will be lost.

      Note: The following error message can be safely ignored:

      The extension Grafana was removed with errors: Error: GraphQL error: external server error

  3. Reinstall Extensions > Extensions Catalog > Categories > Monitoring > Advanced Monitoring > Get it free

    Note: Grafana will be installed automatically as a dependency.

Exit mobile version