Plesk

Unable to access/activate Plesk Onyx: The license key is invalid. In order to use the Panel, you need to obtain and install a new valid license key

Symptoms

Cause

Plesk bug with ID #PPPM-9001 fixed in Plesk Onyx 17.8 for Windows on April 17th, 2018. Fix for Plesk for Linux is expected in future updates.

Resolution

For Plesk Onyx 17.8, install the latest Plesk micro-updates.

For Plesk Onyx 17.5 and 17.0, upgrade to the latest Plesk version.

As a workaround:

Plesk for Linux

  1. Connect to a Plesk server via SSH

  2. Move corrupted registry.xml file to another location so it will not be used and restart the Plesk service:

    # mv /etc/sw/keys/registry.xml /root/
    # service sw-engine restart

  3. Scan and repair file system:

    # plesk repair fs -system -y

  4. Retrieve a Plesk license with the command:

    # /usr/local/psa/bin/license --retrieve

  5. Log in to Plesk to re-create the registry.xml file.

    NOTE: In some cases, it will require to re-install…

Exit mobile version