Plesk

Text “p=DKIM1;” is added to domain’s DKIM DNS record after migration between two Plesk servers

Symptoms

Cause

The bug in the Plesk Migrator extension PMT-4640. It is planned to be fixed in one of the next versions of the extension.

Resolution

Until the bug is fixed, as workarounds:

Plesk GUI workaround

  1. Log into Plesk on the target server.

  2. Go to Domains > example.com > DNS Settings.

  3. Edit the TXT record default._domainkey.example.com so it looks like follows:

    default._domainkey.example.com. TXT v=DKIM1; p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQDxHiIayxdVAy0BDmv+W/6+hUHoDPfzgPc2DFqubFraw8C2zyuudKJtMFAp3OiogVCntMU+7WwQ3wbBS6q9mNy5F8KHHdy9hTMjjrMCRpkzylAVPVvaoAZFBIPDyTDT+0rmx9sIEkGUoliWdpHceePNgtxn9oXbvlE1BTzKz9OtVwIDAQAB;

Bulk workaround over CLI

  1. Connect to the Plesk server via SSH.

  2. Backup Plesk database.
  3. Create a list of DNS zone ids where "p=DKIM1;" is found:

    # plesk db -N -e "select dns_zone_id from psa.dns_recs where displayHost like 'default._domainkey.%' and (val like '% p=DKIM1;%' or displayVal like '% p=DKIM1;%');" >> dns_zone_ids.txt

  4. Verify if the domain names are the migrated ones which need the correction:

    # for id in `cat dns_zone_ids.txt`; do plesk db "select dz.name, dz.id from dns_zone as dz where dz.id=$id;";done

  5. Based on the output of step 4, remove…