Plesk

Subscription does not appear in the list of subscription during migration from cPanel to Plesk

Symptoms

Cause

cPanel misconfiguration; system user of the subscription belongs to non-existing reseller according to /etc/trueuserowners file in cPanel server:

# grep example /etc/trueuserowners
example: jdoe

Resolution

Note: the steps 1-6 are done on the cPanel server. If you experience any difficulties with these steps contact cPanel support directly.

  1. Connect to the cPanel server via SSH.

  2. Create a backup of the configuration file:

    # cp -a /etc/trueuserowners{,.bak}

  3. Modify file /etc/trueuserowners and set the current reseller name to the subscription user:

    Before:

    example: jdoe

    After:

    example: root

  4. Log in to the cPanel.

  5. Go to Account Functions > Modify an Account. Select example.com and press Modify.

  6. Press Save without any changes.

  7. Log in to Plesk.

  8. Go to Tools & Settings > Migration & Transfer Manager > List of subscriptions and press Reload Source Data.

  9. Select "example.com" from the list and press Migrate.