Plesk

Several actions in Plesk are queued/stuck: Cannot read process exit code from file

Symptoms

Cause

The Windows OS was upgraded in-place, or there are 3rd party services installed on the server that conflict with PleskTaskManager.

Resolution

Migrate Plesk to clean installation of Windows OS.

As a temporary workaround the steps below can be used:

  1. Connect to the server via RDP.

  2. Open Start > services.msc.

  3. Find the "Plesk Task Manager Service" in the list and restart it.