Plesk

Plesk server hosted in OVH SAS unable to send mail to Outlook or Hotmail recipients: Please contact your Internet service provider since part of their network is on our block list

Symptoms

Cause

Recently, UCE Protect has placed over a thousand new ASNs on their blacklist. One of OVH SAS' ASNĀ  has been listed on the UCEPROTECTL3 blacklist.

Resolution

Contact OVH to get a new IP that is not blacklisted or set up an External SMTP server in Plesk as per the article How to configure an external SMTP server in Plesk: