Plesk

Plesk repair db shows an error: There is no IP pool with ID 0

Symptoms

Cause

Database inconsistency caused by invalid pool_id records in the clients table of the Plesk (psa) database.

Resolution

Click on a section to expand

Via Plesk GUI

  1. Log into Plesk

  2. Go to Domains > example.com > Hosting Settings > Hosting Type > [Change] > Click OK to re-apply the settings

Via SSH

  1. Connect to the server via SSH

  2. Check that the affected domain doesn't have the web hosting enabled:

    # plesk bin site -i example.com | grep "Hosting type"
    Hosting type: none

  3. If the previous command shows none, disable again the Hosting for the affected domain:

    # plesk bin site -u example.com -hosting false

Additional information

How to access the Plesk psa database in MySQL/MariaDB

Diagnose & Repair tool detected issues with the database: Checking the Plesk database using the native database server tools

Plesk Repair Utility | Plesk Obsidian documentation

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