Plesk

Plesk operations show errors: error setting certificate verify locations: CApath: none

Symptoms

Cause

The cacert.pem file located in %plesk_dir%adminconf is corrupted or missing.

Resolution

Solution for Windows

  1. Connect to the Plesk server via RDP

  2. Download the cacert.pem file from the curl website.

  3. Put the downloaded cacert.pem file to %plesk_dir%adminconf.

  4. Ensure that the following directives in %plesk_dir%adminconfphp.ini contains a valid path to the cacert.pem

    curl.cainfo="C:Program Files (x86)Pleskadminconfcacert.pem"
    openssl.cafile="C:Program Files (x86)Pleskadminconfcacert.pem"

Solution for Linux

  1. Connect to the server using SSH.

  2. Download the CA certificate from the official cURL website 

    # wget https://curl.haxx.se/ca/cacert.pem

  3. Replace /etc/pki/ca-trust/extracted/pem/tls-ca-bundle.pem file

    # mv cacert.pem /etc/pki/ca-trust/extracted/pem/tls-ca-bundle.pem

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