Plesk

Plesk migration error: Failed to copy mail content of subscription because of a network related issue

Symptoms

  1. Plesk migration error:

    Failed to copy mail content of subscription. Most probably that happens because of a network-related issue. Please check network connections between source and target servers, then re-copymail content with the help of 'copy-mail- content' command

    or:

    Failed to copy web files for subscription. Migration tools tried to perform operation in 3 attempts: Rsync failed to copy files from the source (the source server 'source') to the target server (target Plesk server). This could happen because of a network connection issue. Retry copying the files with the help of the "copy-content" command.

  2. Errors in %plesk_dir%varmodulespanel-migratorsessionsYYYYMMDDHHMMSSdebug.log on Windows or /usr/local/psa/var/modules/panel-migrator/sessions/YYYYMMDDHHMMSS/debug.log on Linux:

    |E|ST1|core.windows_rsync|example.com|Interaction via rsync with server at 203.0.113.2 and client at 203.0.113.3 was failed, retry in 10 seconds
    rsync error: error in socket IO (code 10)
    rsync: failed to connect to 203.0.113.2: Connection timed out (116)

Cause

Rsync utility cannot communicate with mail server. It can be source Plesk server or remote mail server.

Resolution

  1. Run RPC Agent manually on the source server or remote mail server. The instructions can be found in this article 
  2. Temporarily disable firewall and antivirus on the source server or adjust settings to allow connections to the target server. The list of ports to allow can be found here.

Exit mobile version