Plesk

Plesk is not accessible with error 500: The FastCGI process exited unexpectedly, error code 0x00000000

Symptoms

Cause

PHP which is used for serving Plesk site (located in the directory %plesk_dir%adminengine) is corrupted.

Resolution

  1. Connect to the server using RDP.

  2. Back up the directory %plesk_dir%adminengine.

  3. Locate or download the necessary MSI file which contains Plesk's PHP files.

    For example, for Plesk Obsidian 18.0.42 this file is C:ProgramDataPleskInstallercachepoolregularPLESK-WIN_18.0.42_8472dist-windowsplesk-engine.msi (or C:ParallelsInstallerparallelspoolregularPLESK-WIN_18.0.42_8472dist-windowsplesk-engine.msi) and can be downloaded from https://autoinstall-win.plesk.com/PANEL-WIN_18.0.42/dist-windows/plesk-engine.msi

  4. Create a directory for extracting the files from MSI (for example, C:tempMSI).

  5. Unpack the MSI file found in step 3:

    C:> msiexec /a C:ProgramDataPleskInstallercachepoolregularPLESK-WIN_18.0.42_8472dist-windowsplesk-engine.msi /qb TARGETDIR=C:tempMSI

  6. Copy all files from the directory C:tempMSIProgram FilesParallelsPleskadminengine to the directory %plesk_dir%adminengine with replacing the already existing files.

Exit mobile version