Plesk

Plesk is inaccessible: Unable to get PSADb administrator password

Symptoms

Cause

The plesksrv.exe process is hung.

Resolution

Warning: If the process is not shown in Task Manager, kill the process with Process Explorer Sys utility: https://docs.microsoft.com/en-us/sysinternals/downloads/process-explorer

  1. Connect to the Plesk server via RDP.

  2. Start Windows Task Manager and end the plesksrv.exe process.

  3. Start Plesk Management Service from Plesk Services Monitor or Windows Services.

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