Plesk

Plesk Backup Manager takes too long to respond or does not load at all when FTP storage is configured

Symptoms

Plesk Backup Manager loads very slowly and opens with one of the the following warning messages:

Warning: Could not display the list of backups in the FTP Storage: Unable to connect to the remote server. Please check the FTP storage settings.


Warning: Unable to access the storage: Transport error: unable to list directory: Curl error: (7) Couldn't connect to server: Last FTP request: Last FTP response:
Make sure you have entered the correct storage settings. You can check them independently with the command:
curl -v --ftp-pasv --ssl -k -u ftpuser 'ftp://server.example.com//backups/'

Cause

The remote FTP server is unreachable from the Plesk server.

Resolution

  1. Check if the remote FTP server is up and running.

  2. Check if the remote FTP server is available for FTP connections from the Plesk server. Run this command from your Plesk server:

    # curl -v --ftp-pasv --ssl -k -u <ftp_server_address>

     

Additional Information

Additionally, it is possible to reduce FTP server timeout so that Plesk Backup Manager will take less time to open when an FTP server is not reachable:

  1. Connect to the Plesk server via SSH.

  2. Add the following lines to the Plesk configuration file /usr/local/psa/admin/conf/panel.ini:

    Note: All values are in seconds.

    [pmm]
    ftpResponseTimeout = 30
    ftpConnectionTimeout = 150
    ftpRequestTimeout = 150