Plesk

PHP pages on domains in Plesk are downloaded instead of being opened

Symptoms

Cause

PHP support is disabled for the example.com domain in Domains > example.com > PHP Settings.

Resolution

Enable the PHP Support for the example.com website in one of the following ways:

via Plesk Graphical Interface

  1. Log into Plesk.

  2. Navigate to Domains > example.com > PHP Settings.

  3. Select the PHP Support checkbox and press the OK button:

via Command Line Interface (CLI)

  1. Connect to the server via SSH or RDP.

  2. For Plesk for Windows, additionally start the Command Prompt.
  3. Execute the following command:

    Note: change the "example.com" domain in the command below to the correct one

    # plesk bin subscription -u example.com -php true

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