Plesk

Outgoing mail control rejects outgoing mail before limit has been reached

Symptoms

Outgoing mail control rejects outgoing mail before the limit specified on a mailbox, domain or a subscription level has been reached.

For example, limit of outgoing mail for a mailbox is equal to 250. However, messages are rejected after reaching the limit of 10 per hour with a similar error:

5.7.0 Your message could not be sent. The limit on the number of allowed outgoing messages was exceeded. Try again later..

Cause

Database inconsistency.

Data mismatch between Plesk psa database and SQlite database /var/lib/plesk/mail/outgoing/data.db used by mail server to limit outgoing email.

Resolution

  1. Connect to the server via SSH;

  2. Run the following command to repair /var/lib/plesk/mail/outgoing/data.db:

    # plesk repair mail example.com

  3. If the issue is server-wide, re-create the file for all domains on a server:

    # plesk repair mail