Plesk

Outbound emails do not pass DKIM verification when DNS is hosted externally

Symptoms

Cause

TXT record for default._domainkey.example.com. which is set in Plesk > domains > example.com > DNS Settings does not match with globally propagated DNS TXT record:

# dig +short TXT default._domainkey.example.com @203.0.113.2
"v=DKIM1; p=MIGfMA0GCSqGSIb3DQEBAQU111...
# dig +short TXT default._domainkey.example.com @8.8.8.8
"v=DKIM1; p=MIGfMA0GCSqGSIb3DQEBAQUAA4...

Resolution

Update the DNS TXT record default._domainkey.example.com:

  1. Log into Plesk
  2. Retrieve the value for the DNS TXT DKIM record at Domains > example.com > Mail Settings > How to configure external DNS
  3. Set the DNS record in external DNS server to the value retrieved in step 2. or contact DNS server owner to synchronize TXT accordingly