Plesk

Node.js menu on a migrated subscription in Plesk doesn’t work: Call to a member function getPath() on null

Symptoms

Cause

Product issue:

  • #EXTNODEJS-122 "Opening the extension on domains with non-existent handlers no longer results in external Server Error 500."

    Fixed in:

Resolution

Please consider updating your server:

Workaround

If update is not possible for some reason you may try the following

workaround

As a workaround apply one of the following alternatives:

  • Re-install Node.js extension by removing and installing this again with this instructions.

  • Update the the ext-nodejs-handlerPath on the database:

    1. Connect to the server via SSH

    2. Backup the Plesk 'psa' database

    3. Login to the database

      # plesk db

    4. Modify the ext-nodejs-handlerPath to /opt/plesk/node/16/bin/node:

      # update dom_param set val='/opt/plesk/node/16/bin/node' where dom_id=(select id from domains where name='example.com' limit 1) and param='ext-nodejs-handlerPath';

      Note: Change example.com and the node version 16 accordingly based on the versions found on the server.

    5. Log into Plesk

    6. Go to Domains > example.com > Node.js.

    7. Click Disable node.js button.

    8. Click Enabled node.js button.

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