Plesk

MailEnable mail stuck in outgoing queue: Could not resolve MX list for domain

Symptoms

Cause

DNS server configured in MailEnable could not resolve recipient domain IP address.

Resolution

  1. Connect to the server via RDP.

  2. Go to MailEnable console > Servers > localhost > Services and Connectors > SMTP > Properties > General tab.

  3. Configure DNS servers IP addresses. For example, Google DNS servers IP could be added: 8.8.8.8 or 4.4.4.4:

    Note: SMTP server must be restarted to apply changes, if any (Servers > localhost > Services and Connectors > SMTP > Stop/Start).

  4. If the error still persists, make sure that the server is able to resolve any public host:

    C:> ping google.com
    Ping request could not find host google.com. Please check the name and try again.

    If the output is like above, contact the network administrator.