Plesk

Mailbox can not be created on a Plesk for Windows server: Unable to update the mail account properties: mailmng failed: MEAOPO.Mailbox.AddMailbox failed for name=jdoe and domain example.com

Symptoms

Cause

Too strict security settings in MailEnable Enterprise edition.
Such behavior was confirmed as Plesk bug with ID PPPM-11921 and Plesk Migrator extension bug with ID PMT-4837.

Resolution

  1. Log into Plesk.

  2. Go to Domains > example.com > Mail tab > Mail Accounts and remove the affected mailbox jdoe@example.com from Plesk.

  3. Connect to the server via RDP.

  4. Open MailEnable > Servers > right-click on localhost > in the opened window switch to the Policies tab > disable the options Lock out user for one hour after and Enforce password policy and apply changes:
    img.png

  5. Re-create mailbox in Plesk.
  6. For migration cases, additionally, re-migrate the affected subscription as per the following article.

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