Plesk

Mail users with iOS and MacOS devices cannot access mail after certificate renewal on Plesk server: Cannot Verify Server Identity

Symptoms

Cause

iOS / MacOS issue: system does not allow the user to "trust" a SSL/TLS certificate after renewal

Resolution

There are two possible solutions:

Solution 1. Recreate mail accounts devices

 

Solution 2. Manually install and allow using required SSL certificates from device settings:

  • Press F12 > Security > View certificate.
  • On the new opened window go to the Details tab and click on Copy file.
  • It will open the export wizard. Click on Next.
  • Select "DER binary coded X.509 (.CER)" and click Next.
  • Select a name for the file and click Next
  • Review the information and click on Finish

Note: Interfaces on different versions of iOS / MacOS may vary.

Additional information

Exit mobile version