Plesk

Mail stuck in queue on Plesk server: delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused

Symptoms

Cause

The server's hostname is not a fully qualified domain name.

Resolution

  1. Log into Plesk

  2. Navigate to Tools & Settings > Server Settings and change Full hostname to temporary one (for example temp.server.example.com)

  3. Press OK

  4. Open Tools & Settings > Server Settings and change Full hostname back to the original fully qualified domain name again and press OK

  5. Connect to the server via SSH

  6. Make sure that "$myhostname" variable inside the /etc/amavisd/amavisd.conf is equal to the hostname set in step 4.
  7. Start amavis service:

    • On RHEL based operating system:

      # service amavisd start

    • On Debian based operating system:

      # service amavis start

Note: Make sure the hostname is not set to a non-fully qualified domain name by a hypervisor in case the problem reappears.