Plesk

Mail is not sent or received on Plesk Windows server: queue overflowed

Symptoms

Cause

Too big (more than 20 000) outgoing queue in %plesk_dir%Mail ServersMail EnableQueuesSMTPOutgoing and/or %plesk_dir%Mail ServersMail EnableQueuesSFOutgoing

Resolution

As a workaround, rename the outgoing queue folder:

  1. Connect to the server via RDP.
  2. Rename directory %plesk_dir%Mail ServersMail EnableQueuesSMTPOutgoing and/or %plesk_dir%Mail ServersMail EnableQueuesSFOutgoing.
  3. Create a new directory %plesk_dir%Mail ServersMail EnableQueuesSMTPOutgoing and/or %plesk_dir%Mail ServersMail EnableQueuesSFOutgoing.
  4. Create subdirectory "Messages" in %plesk_dir%Mail ServersMail EnableQueuesSMTPOutgoing and/or %plesk_dir%Mail ServersMail EnableQueuesSFOutgoing.
  5. To send the deferred messages, move them from the renamed directory to the new one in bunches by 1000 files and wait for them to be sent (disappeared from the directory).
Exit mobile version