Plesk

Mail from Plesk server is rejected with error: 550-5.7.1 is likely unsolicited mail

Symptoms

Cause

SPF record is not set properly.

Resolution

Using Plesk Interface

  1. Log in to Plesk.

  2. Go to Domains > example.com > DNS Settings.

  3. Check the syntax of SPF record according to the article How to check whether a domain has a correctly set SPF record?

    If a domain does not have an SPF record, add it by clicking Add Record, selecting TXT Record Type:

    v=spf1 +a +mx -all:

Using SSH/RDP connection

Connect to the server via SSH/RDP and execute the following command in the Command Prompt or Linux Shell:

on Windows :

C:> plesk bin dns --add example.com -txt "v=spf1 +a +mx -all"

on Linux :

# plesk bin dns --add example.com -txt "v=spf1 +a +mx -all"

Note: if SPF record was updated recently wait till proper SPF record will be propagated 12-24h