Plesk

Mail client shows warning connecting to Plesk mail server: the server to which you are connected uses a security certificate that can not be verified. The main destination name is not valid

Symptoms

Cause

Wrong hostname is specified as a mail server in Mail client.

Resolution

Mail clients must use the same name for Incoming and Outgoing mail server as specified in Tools & Settings > SSL/TLS Certificates Certificate for securing mail.

For example for Outlook under File > Account Settings  > user@example.com > Change Account specify Mail server's hostname in the Incoming mail server and Outgoing mail server (SMTP) fields.

Note: the mail server hostname has to be the same as (or included) in the certificate. To know what certificate is being used by the Mail Server, on Plesk go to: Tools & Settings > SSL/TLS Certificates Certificate for securing mail or contact your service provider.

Additional information

How to enable 587 submission port on Linux?

How to enable submission port 587 in MailEnable?

How to assign separate SSL certificates for different domains on a local mail server in Plesk?