Plesk

License was not automatically updated in Plesk: KeyUpdate Result code: 2 Network failure

Symptoms

Cause

The corrupted file /etc/sw/keys/registry.xml or Plesk licensing server (Key Administrator) is overloaded with the same requests.

Resolution

  1. Connect to the server via SSH.

  2. Remove the /etc/sw/keys/registry.xml file:

    # rm /etc/sw/keys/registry.xml

  3. Log out from Plesk interface and log into back to recreate the removed /etc/sw/keys/registry.xml file.

  4. Run Daily Maintenance task to update keys on the server:

    # plesk daily

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