Plesk

Import/export of a remote MS SQL Server database fail in Plesk: Unable to connect to the network share Unable to open network connection: A specified logon session does not exist. It may already have been terminated

Symptoms

When exporting/importing a Microsoft SQL database or applying new backup settings for a remote MS SQL Servers at Tools & Settings > Database Servers > remote_MSSQL_ServerName > Backup section, the operation fails with the error message:

Unable to open network connection: A specified logon session does not exist. It may already have been terminated
(Error code 21)

Cause

Incorrect database user name specified in connection settings: the user on the remote server is set without network specification:

john_doe

Resolution

  1. Log in to Plesk.

  2. Go to Tools & Settings > Database Servers > remote_MSSQL_ServerName > Backup section.

    Specify server name or IP address of the remote server with Microsoft SQL Server.

    203.0.113.2john_doe

  3. Click OK to apply the changes.

 

Additional information